Очистка портов во FreeBSD


Майкл Лукас
перевод Романа Игнатова
Оригинал статьи: Cleaning Up Ports

Несмотря на то, что все хвалят систему портов FreeBSD, в ней есть ограничения. Одно из ограничений действительно уменьшает другие сильные стороны FreeBSD - это система апгрейда. Взаимодействие с которой использует очень неуклюжий путь.

Процесс инсталляции портов записывает каждый файл порта, включая все зависимости. Например, много портов требуют графическую библиотеку PNG. Записи порта указывают на точную версию библиотеки PNG, которая требуется, например версия 1.0.11. В общем, это та же версия, которая находится в вашем дереве портов. Процесс модернизации (апгрейда) во FreeBSD может обновить только версии программ, что есть в дереве портов. Например, библиотека PNG была недавно обновлена до версии 1.0.12. Номер основной версии не увеличился, но в новой библиотеки (промежуточной версии) были сделаны некоторые исправления ошибок. Мне хочется обновить свою версию. Если я это сделаю - более тридцати портов, в которых указана ТОЧНАЯ версия PNG-библиотеки, будут иметь неправильные записи (ссылки на библиотеку).

В моем ноутбуке установлено 187 пакетов. В основном я обновляю свое дерево портов еженедельно, так как порты загрязняются очень быстро и вскоре их становится невозможным использовать. К счастью Akinori MUSHA шагнул вперед, создав инструмент позволяющий разобраться в этом мусоре: portupgrade и другие.

Инструменты, включенные в portupgrade, реализуют некоторые новые возможности в системе портов FreeBSD. Во-первых это pkgdb и portdb, которые создают базу данных, индексируя /var/db/pkg и дерево портов.

Это ускоряет поиск и манипуляцию этой информацией. Эти инструменты также перезаписывают различные /var/db/pkg файлы для сохранения согласованности (для сохранения зависимостей). И наконец, они - надстройки для различных pkg_* комманд, которые оперируют и с базой данных, и с текстовыми записями, когда вы добавляете или удаляете ту или иную программу. Все эти инструменты вы можете получить, установив из портов /usr/ports/sysutils/portupgrade.

Перед тем как вы начнете использовать portupgrade, забекапте /var/db/pkg! У меня никогда небыло никаких проблем с этой программой, но все инструменты, которые непосредственно изменяют системную информацию, имеют безграничный потенциал сделать вашу жизнь трудной. Если вы полностью уничтожите информацию о ваших пакетах, вы сможете восстановить их из бекапа.
$ tar -czvf dbpkg.tgz /var/db/pkg

Запустите pkgdb -F, чтобы начать установку и выполнить некоторую основную очистку. Если у вас много портов и вы давно делали обновление дерева портов, при первом запуске эта операция может занять много времени. Как только вы построили базу данных, использование станет легче и быстрее; это только первый раз занимает много времени.
$ pkgdb -F
Checking the origin of Hermes-1.3.2
Checking the origin of Mesa-3.4.1
Checking the origin of Mesa-3.4.2_1
Checking the origin of ORBit-0.5.10_5
Checking the origin of XFree86-aoutlibs-3.3.6.9
...

Проходя по всем пакетам с измененными (неправильными) зависимостями, pkgdb будет спрашивать вас, хотите ли вы исправить неверные зависимости.
Stale dependency(устаревшая зависимость):
esound-0.2.22 -> libaudiofile-0.2.2:
libaudiofile-0.2.1_1 ?
([y]es/[n]o/[a]ll) [yes]

Итак, esound зависит от libaudiofile версии 0.2.2, но текущая установленная версия 0.2.1_1. Я, видимо, сделал бы pkg_add -f в недалеком прошлом, думая что это должно работать, несмотря на некоторое различие в номерах версий. (Так и было). Итак pkgdb спрашивает хочу ли я обновить мои записи в /var/db/pkg/esound-0.2.22/+CONTENTS, чтобы они указывали на версию libaudiofile, которая установлена в системе. Если я соглашусь с предложением по умолчанию, pkgdb подкорректирует записи.

Если я напечатаю а, pkgdb подкорректирует не только записи libaudiofile для esound, но и для всех других пакетов, которые используют libaudiofile. Это очень удобно для пакетов, которые имеют много зависящих (от них) пакетов, например как PNG.

В предыдущем примере pkgdb оказался способным догадаться о зависимости. В других случаях он может вообще ни о чем не догадываться. Например, я собирал XFree86 из CVS репозитория xfree86.org. imake - это часть XFree86, поэтому у него нет записи в /var/db/pkg. Это нормально. Процесс port-building проверяет существующие программы, не по их записям в /var/db/pkg. При инсталляции портов записи помещаются в /var/db/pkg, тем не менее, считается что порт установлен, если найдена соответствующая программа (Это, возможно, недостаток в системе портов, но это не так просто исправить).

Что случится, когда в списке портов будет зависимость от imake, pkgdb "заглохнет".
Stale dependency: Xaw3d-1.5 - imake-4.1.0:
New dependency? (? to help): ?

Здесь у меня есть выбор. Я могу назначить новую зависимость, или я могу сообщить пакету, что это не зависимость.
[Enter] to skip, [Ctrl]+[D] to delete,
[.][Enter] to abort,
[Tab] to complete
New dependency? (? to help):
Control-D it is.
Delete this? ([y]es/[n]o/[a]ll) [yes]
Deleted.

Если я выберу yes, будет удалена только эта зависимость. Если я выберу all эта зависимость будет удалена везде где встретится. Множество портов используют imake; Я хочу удалить все эти зависимости.

Смотрим дальше:
Stale dependency: xneko-4.4 - XFree86-libraries-4.1.0:
Delete this? ([y]es/[n]o/[a]ll) [yes] Deleted.

Другой случай, это действительно зависимость, которую pkgdb не может распознать правильно.
Stale dependency: plugger-3.3_1 - timidity++-esound-2.10.4:
New dependency? (? to help): ?
[Enter] to skip, [Ctrl]+[D] to delete,
[.][Enter] to abort, [Tab] to complete
New dependency? (? to help): timidity++-2.10.4

Завершение табом делает это выполнимым. Я знаю, что timidity++-esound использует какую-то версию timidity, но я но я не хочу перерывать всё в поисках точного номера версии. Я могу напечатать несколько первых букв и нажать таб (tab), и спокойно получить полное имя пакета. И наконец, процесс pkgdb будет предупреждать вас о дубликатах.
Duplicated origin: graphics/Mesa3 - Mesa-3.4.1 Mesa-3.4.2_1
Remove any of them? [no]

Здесь у меня проблема. Нередко случается ситуация, когда вы устанавливаете программу из пакета, и он требует для установки другой пакет. У вас могут быть одновременно установлены разные версии пакетов. Если вы устанавливаете из пакетов, это автоматически устанавливает требуемые пакеты, даже если в системе уже установлены немного другие версии этих пакетов. Что-то похожее произошло и в моей системе. Мой ноутбук имеет две разные версии Mesa, но одна версия перезаписана другой. Очевидно это не может быть очень плохо, так как моя система нормально работает (в конце концов мне следует полностью удалить Mesa и установить свежую версию). Итак мне нужно очистить базу данных портов. Я спокойно удалил более старую версию.

Итак теперь у вас есть база данных информации об установленных пакетах в /var/db/pkg/pkgdb.db. Также у вас должна быть база данных портов в /usr/ports/index.db и /usr/ports/index.dbo (у меня /usr/ports/INDEX.db и /usr/ports/INDEX-5, прим. перев.) Различные инструменты portupgrade используют эти базы данных в своей работе. Всякий раз, когда вы обновляете ваше дерево портов, обновляется база данных портов и /usr/ports/INDEX. Вы можете это сделать в любой момент, просто запустив portsdb -Uu.

Теперь, когда мы установили необходимые инструменты, давайте посмотрим, что мы можем сделать. Чтобы увидеть какие программы в системе устарели, используйте portversion. Он работает также как и pkg_info, но намного быстрее.
$ portversion
Hermes =
Mesa =
ORBit <
XFree86-aoutlibs <
Xaw3d =
aalib =

Символ < означает, что установленная версия старее, чем текущая версия в дереве портов. Вы можете просто запустить portversion | grep '<', чтобы увидеть версии каких программ устарели. Я так поступаю часто просто для того, чтобы посмотреть что установлено на моей системе. Например, мой пакет Apache устарел. Тем более я давно не использую Apache на моем ноутбуке, поэтому я могу спокойно его удалить. Можно воспользоваться стандартной утилитой pkg_delete, но если я её использую - моя база данных пакетов не будет соответствовать действительному состоянию моей системы. Вместо этого я использую pkg_deinstall.
$ pkg_deinstall apache
---< Deinstalling 'apache-1.3.20'
[Updating the pkgdb in /var/db/pkg ... - 182 packages found (-1 +0)
(...) done]

Здесь есть интересная особенность, мне не нужно больше указывать полностью номер версии! (Это утомляло меня некоторое время в стандартных утилитах FreeBSD pkg_*, но теперь я от этого избавился).

Утилиты portupgrade используют универсальные функции, которые дают возможность искать совпадения по шаблону.

Предположим я хочу обновить некоторые порты. К тому же, я хочу обновить сохраняя синхронизацию с базой данных, внося походу корректировки в записи в /var/db/pkg. Например, pkgversion показывает мне, что библиотека gd устарела. Можно легко обновить требуемый пакет:
$ portupgrade gd
===> Cleaning for gettext-0.10.35
===> Cleaning for gmake-3.79.1
===> Cleaning for libtool-1.3.4_2
===> Cleaning for jpeg-6b
===> Cleaning for png-1.2.0
===> Cleaning for freetype2-2.0.5
===> Cleaning for gd-1.8.4_4
If you want to compile in X support use
'make -DWITH_X11' instead
===> Extracting for gd-1.8.4_4
....

Вы увидите такой же вывод как от make. Если вы посмотрите дальше, вы увидите как утилита удаляет установленные пакеты, обновляет базу данных и так далее.
...
---> Deinstalling 'gd-1.8.4_3'
pkg_delete: package 'gd-1.8.4_3' is required
by these other packages and may not be deinstalled
(but I'll delete it anyway): scr2png-1.1
[Updating the pkgdb in /var/db/pkg ... -
180 packages found (-1 +0) (...) done]
===> Installing for gd-1.8.4_4
...

После окончания установки, утилита снова обновит базу данных пакетов.

Теперь всё опять синхронизированно.

Теперь давайте рассмотрим некоторые возможные трудности. Мой порт docproj устарел. Он не зависит не от каких других пакетов, но на него ссылаются все инструменты, необходимые для редактирования FreeBSD Documentation Project. Если вы регулярно строите дерево документации, вам необходим этот инструмент, чтобы отвечать современным требованиям (быть актуальным). Также вы не хотите рекурсивно пересобирать все пакеты из-за незначительного обновления docproj, который имеет огромные зависимости.

Если я хочу сохранить массу времени, мне следует использовать portupgrade -P. Время - это то чего всегда не хватает моему компьютеру, поэтому я использую порты. Нам надо дать задачу portupgrade, чтобы он рекурсивно обновлял пакеты, которые ссылаются на docproj. Вы можете сделать это с помощью флага -R. Давайте так и сделаем:
$ portupgrade -R docproj
This port will try to ensure that
the tools used by the FreeBSD Documentation Project
are installed on your system so you can convert
documentation from SGML to other formats.

Один из таких компонентов это JadeTeX, который зависит от TeTeX. Исходники для TeTeX "весят" более 30 MB и могут долго скачиваться из сети.

Если вы не хотите создавать PostScript и PDF форматы из документации, вам не нужен JadeTeX, и вам следует установить переменную JADETEX в значение no. Если вы хотите создавать документацию в форматах PostScript и PDF, тогда установите переменную JADETEX в yes.

Например:
make JADETEX=no
make JADETEX=yes
*** Error code 1
Stop.
** Command failed: make clean build
** Fix the problem and try again.
** The following packages were not installed
or upgraded (-:skipped / !:failed)
! textproc/docproj (docproj-1.4) (unknown build error)

Ой! Этот порт требует настройки. Вы можете отредактировать /usr/ports/textproc/docproj/Makefile, добавив строчку JADETEX=no. Теперь должно всё пройти нормально.

Когда вы закончите, мы можете проверить, как установились новые версии портов. Возможно, вы обнаружите, что в других портах изменились зависимости, например, порт А ссылается на порт В (зависит от порта В) и порт С также ссылается на порт В, запустите portupgrade A и он не будет редактировать зависимость порта С, но только свою. Будьте готовы запустить pkgdb -F, чтобы найти и исправить такие проблемы.

Если вы хотите, чтобы система занималась этим процессом самостоятельно, вы можете использовать portupgrade -rR; это будет обновлять обе зависимости. Если вы всегда хотите иметь в своей системе самые свежие программы, то есть возможность сделать и это. portupgrade включает целый ряд других инструментов для легкого управления программным обеспечением на FreeBSD, но этого пока достаточно, чтобы вы могли начать.

Возможно вы захотите переустанавливать один порт несколько раз из одного distfile. Если порт будет обновлен, portversion обнаружит это и пометит его как устаревший. Если вы захотите оставить дистфайлы для портов, которые уже установлены, но удалить устаревшие дистфайлы, используйте portsclean -D. Аналогично, вы возможно захотите удалить расшаренные библиотеки, на которые нет ссылок в базе данных пакетов. Я не хочу использовать опцию --remember, я установил XFree86 из архива, не из портов. Эта функция удалит мой X сервер, ой! Но portsclean -L может помочь в этой ситуации и решить эту проблему, также как мою неправильную установку Mesa.

И наконец я хочу сказать, что этот инструмент довольно надежный. К тому времени, как я закончил эту статью, я запустил эти программы, чтобы проверить мои примеры. Я нашел один устаревший пакет и дал команду обновить и его:
$ portupgrade -R portupgrade

Да, это работает. Хочу сказать - этот инструмент безусловный победитель.

www.opennet.ru

Обновлено: 12.03.2015